Recent Articles

Server Load Balancing (SLB)
When you´re working on your BCMSN exam on your way to CCNP certification, you´ll read at length about how Cisco routers and multilayer switches can work to provide router redundancy - but there´s another helpful service, Server Load Balancing, that does the same for servers.

Sun Sees Red, Sues Azul
Sun Microsystem's acquisition of Cobalt Networks in September 2000 has made it back into the headlines, as Sun files a lawsuit against former Cobalt and current Azul CEO Stephen DeWitt over theft of trade secrets and violation of a non-compete agreement.

Who Will Win The Switch Wars?
Why is it that people can look at a simple sentence - and interpret it in so many ways?

Can't Connect to Internet
We talked about DNS problems at Fallure to resolve, but there are other reasons why a particular machine may be unable to browse the Internet while others on the same lan still can.

Cisco Rounding Up Digital Talent
A $250,000 promotion conducted by networking giant Cisco and Viacom's mtvU college network will support a "Digital Incubator" for broadband content.

Who Said That?
My wife and I had run out for errands and had stopped at a D'Angelo sub shop. We were just about to get out of the car when the phone rang. My wife rolled her eyes but I took the call because, well, because that's what I do. Somebody has a problem, I try to answer the phone.

BGP Adjacency States
To pass the BSCI exam, earn your CCNP certification, and become an outstanding networker, you´ve got to master the many details of BGP - and trust me, there are a lot of details to master!

Dynamic Trunking Protocol (DTP)
When you´re studying to pass the BCMSN exam on the way to earning your CCNP certification, you´re going to add to your CCNA knowledgebase every step of the way.

Static VLANs
BCMSN exam success and earning your CCNP certification requires you to add to your knowledge of VLAN
configuration.

Keep in touch (tcp keepalives etc.)
You can't please everyone, so you got to please yourself...I don't imagine Ricky Nelson was thinking about tcp timeouts and keepalives in the 70's...

Senator Proposes Net Neutrality Bill
Ron Wyden (D-Or) has introduced legislation to prevent telecoms and cable companies from developing a two-tiered network where fees would be charged to content providers to prioritize their Internet traffic...

Open Source Vyatta Takes On Hardware

After years of open source projects like Linux and MySQL taking share from proprietary software companies, hardware makers like Cisco and Juniper get to experience the heart-stopping terror of open source hardware hitting the market...

05.30.06


Route Summarization And The OSPF Null Interface

By Chris Bryant


CCNP exam success, particularly on the BSCI exam, demands you understand the details of route summarization.

This skill not only requires that you have a comfort level with binary conversions, but you have to know how and where to apply route summarization with each individual protocol.

You also have to know the "side effects" of route summarization. With OSPF, there will actually be an extra interface created at the point of summarization, and this catches a lot of CCNP candidates by surprise. Let's take a look at the null0 interface and how it relates to OSPF summarization.

On R1, the following networks are redistributed into OSPF, and then summarized.

interface Loopback16

ip address 16.16.16.16 255.0.0.0

interface Loopback17

ip address 17.17.17.17 255.0.0.0

interface Loopback18

ip address 18.18.18.18 255.0.0.0

interface Loopback19

ip address 19.19.19.19 255.0.0.0

R1(config)#router ospf 1

R1(config-router)#redistribute connected subnets

R1(config-router)#summary-address 16.0.0.0 252.0.0.0


The summary address appears on R2, a downstream router.

R2#show ip route ospf

O E2 16.0.0.0/6 [110/20] via 172.12.123.1, 00:00:05, Serial0


Learn More about our dedicated servers

Let's go back to R1 and look at its OSPF table.

R1#show ip route ospf

O 16.0.0.0/6 is a summary, 00:01:51, Null0


Where did the null0 interface come from, and why is it there? Packets sent to the null interface are dropped, and in this case, that's a good thing.

When you configure summary routes in OSPF, a route to null0 will be installed into the OSPF routing table. This helps to prevent routing loops. Any packets destined for the routes that have been summarized will have a longer match in the routing table, as shown below...

C 17.0.0.0/8 is directly connected, Loopback17

C 16.0.0.0/8 is directly connected, Loopback16

C 19.0.0.0/8 is directly connected, Loopback19

C 18.0.0.0/8 is directly connected, Loopback18

O 16.0.0.0/6 is a summary, 00:01:51, Null0


.. and packets that do not match one of the summarized routes but do match the summary route will be dropped.

Preventing routing loops when performing route redistribution and summarization is vital. OSPF gives us a little help in that regard in this situation, and as you study more complex redistribution scenarios on your way to the CCNP and CCIE, you'll realize that we'll take all the help we can get!


About the Author:
Chris Bryant, CCIE #12933, is the owner of The Bryant Advantage, home of FREE CCNA and CCNP tutorials and daily exam questions, as well as The Ultimate CCNA and CCNP Study Packages.

About NetworkNewz
NetworkNewz editors, writers and contributors focus on both the big picture and the details of networking. At NetworkNewz our goal is to deliver to you The Key To Network Management.

NetworkNewz is brought to you by:

SecurityConfig.com NetworkingFiles.com
ITmanagementNews.com WebProASP.com
DatabaseProNews.com SQLProNews.com
ITcertificationNews.com SysAdminNews.com
LinuxProNews.com WirelessProNews.com
CProgrammingTrends.com ITmanagementNews.com


-- NetworkNewzis an iEntry, Inc. publication --
iEntry, Inc. 2549 Richmond Rd. Lexington KY, 40509
2006 iEntry, Inc.  All Rights Reserved  Privacy Policy  Legal

archives | advertising info | news headlines | free newsletters | comments/feedback | submit article


The Keys To Network Management Ask Questions in the Networking Forum NetworkNewz News Archives About Us Feedback NetworkNewz Home Page About Article Archive News Downloads WebProWorld Forums Jayde iEntry Advertise Contact